Asus V7-P7H55E - FreeBSD - 2013 archive

Back to main FreeBSD page for this machine.

2013 archive

2013-12-15: ad4s1a - copy image to CF card. Since the v2 machine failed to read the CF card, I'll try here. Insert CF card, which is automatically detected:

root@kg-v7# grep da1 /var/log/messages
Dec 16 00:09:44 kg-v7 kernel: da1 at umass-sim0 bus 0 scbus0 target 0 lun 1
Dec 16 00:09:44 kg-v7 kernel: da1: <Generic CF Card Reader 1.01> Removable Direct Access SCSI-0 device
Dec 16 00:09:44 kg-v7 kernel: da1: 40.000MB/s transfers
Dec 16 00:09:44 kg-v7 kernel: da1: 991MB (2031120 512 byte sectors: 64H 32S/T 991C)

and the devices hows up too:

root@kg-v7# ls -l /dev/da1*
crw-r-----  1 root  operator    0, 128 Dec 16 00:09 /dev/da1
crw-r-----  1 root  operator    0, 129 Dec 16 00:09 /dev/da1s1

disktype info:

tingo@kg-v7$ disktype /dev/da1

--- /dev/da1
Character device, size 991.8 MiB (1039933440 bytes)
DOS/MBR partition map
Partition 1: 991.2 MiB (1039385088 bytes, 2030049 sectors from 63, bootable)
  Type 0x06 (FAT16)
  Windows / MS-DOS boot loader
  FAT16 file system (hints score 5 of 5)
    Volume size 991.0 MiB (1039106048 bytes, 63422 clusters of 16 KiB)

images:

tingo@kg-v7$ ls -lh *img
-r--r--r--  1 tingo  users    62M Dec 16 00:17 P112 CF Img 10-08-13.img
-r--r--r--  1 tingo  users   1.4M Dec 16 00:17 P112 Flpy Img 10-24-13.img

Next, copy an image:

root@kg-v7# dd if="./P112 CF Img 10-08-13.img" of=/dev/da1 bs=64k
1001+0 records in
1001+0 records out
65601536 bytes transferred in 6.449998 secs (10170784 bytes/sec)

what does disktype say now?

root@kg-v7# disktype /dev/da1

--- /dev/da1
Character device, size 991.8 MiB (1039933440 bytes)

it has changed at least. Now, will it boot in my P112?

2013-11-16: ad4s1a - testing a few cards in the card reader:

root@kg-v7# uname -a
FreeBSD kg-v7.kg4.no 8.3-STABLE FreeBSD 8.3-STABLE #0: Sat Jun 16 14:44:53 CEST 2012     root@kg-v7.kg4.no:/usr/obj/usr/src/sys/GENERIC  amd64

SD card, Lexar 4 GB, class 4, from /var/log/messages:

Nov 16 17:59:36 kg-v7 kernel: da0: <Generic SD Card Reader 1.00> Removable Direct Access SCSI-0 device
Nov 16 17:59:36 kg-v7 kernel: da0: 40.000MB/s transfers
Nov 16 17:59:36 kg-v7 kernel: da0: 3823MB (7829504 512 byte sectors: 255H 63S/T 487C)

disktype

root@kg-v7# disktype /dev/da0

--- /dev/da0
Character device, size 3.733 GiB (4008706048 bytes)
DOS/MBR partition map
Partition 1: 3.729 GiB (4004511744 bytes, 7821312 sectors from 8192)
  Type 0x0B (Win95 FAT32)
  FAT32 file system (hints score 4 of 5)
    Volume size 3.726 GiB (4000317440 bytes, 122080 clusters of 32 KiB)

SD card, Transcend 8 GB, class 10, from /var/log/messages:

Nov 16 18:09:49 kg-v7 kernel: da0: <Generic SD Card Reader 1.00> Removable Direct Access SCSI-0 device
Nov 16 18:09:49 kg-v7 kernel: da0: 40.000MB/s transfers
Nov 16 18:09:49 kg-v7 kernel: da0: 7695MB (15759360 512 byte sectors: 255H 63S/T 980C)

disktype

root@kg-v7# disktype /dev/da0

--- /dev/da0
Character device, size 7.515 GiB (8068792320 bytes)
DOS/MBR partition map
Partition 1: 7.511 GiB (8064598016 bytes, 15751168 sectors from 8192)
  Type 0x0B (Win95 FAT32)
  FAT32 file system (hints score 4 of 5)
    Volume size 7.507 GiB (8060403712 bytes, 245984 clusters of 32 KiB)

CF card, Kingston 4 GB, no speed rating, from /var/log/messages:

Nov 16 18:12:35 kg-v7 kernel: da1: <Generic CF Card Reader 1.01> Removable Direct Access SCSI-0 device
Nov 16 18:12:35 kg-v7 kernel: da1: 40.000MB/s transfers
Nov 16 18:12:35 kg-v7 kernel: da1: 3811MB (7806960 512 byte sectors: 255H 63S/T 485C)

disktype

root@kg-v7# disktype /dev/da1

--- /dev/da1
Character device, size 3.723 GiB (3997163520 bytes)
DOS/MBR partition map
Partition 1: 3.719 GiB (3993034752 bytes, 7798896 sectors from 8064, bootable)
  Type 0x0C (Win95 FAT32 (LBA))
  Windows 95/98/ME boot loader
  FAT32 file system (hints score 4 of 5)
    Volume size 3.715 GiB (3988815872 bytes, 121729 clusters of 32 KiB)
    Volume name "KINGSTON"

That was it, now go test in v2.

2013-11-15: ad4s1a - testing a few CF (CompactFlash) cards in the card reader:

root@kg-v7# uname -a
FreeBSD kg-v7.kg4.no 8.3-STABLE FreeBSD 8.3-STABLE #0: Sat Jun 16 14:44:53 CEST 2012     root@kg-v7.kg4.no:/usr/obj/usr/src/sys/GENERIC  amd64

first out is the Kingmax 2GB 80x, which show up as this in /var/log/messages:

da1 at umass-sim0 bus 0 scbus0 target 0 lun 1
da1: <Generic CF Card Reader 1.01> Removable Direct Access SCSI-0 device
da1: 40.000MB/s transfers
da1: 1919MB (3931200 512 byte sectors: 255H 63S/T 244C)

and this in /dev:

root@kg-v7# l /dev/da1*
/dev/da1    /dev/da1s1

disktype info

root@kg-v7# disktype /dev/da1

--- /dev/da1
Character device, size 1.875 GiB (2012774400 bytes)
DOS/MBR partition map
Partition 1: 1.874 GiB (2012226048 bytes, 3930129 sectors from 63, bootable)
  Type 0x06 (FAT16)
  FAT16 file system (hints score 5 of 5)
    Volume size 1.874 GiB (2011955200 bytes, 61400 clusters of 32 KiB)

Next out is a TEKQ 1GB 80x, from /var/log/messages:

Nov 15 19:17:05 kg-v7 kernel: da1: <Generic CF Card Reader 1.01> Removable Direct Access SCSI-0 device
Nov 15 19:17:05 kg-v7 kernel: da1: 40.000MB/s transfers
Nov 15 19:17:05 kg-v7 kernel: da1: 991MB (2031120 512 byte sectors: 64H 32S/T 991C)

from /dev:

root@kg-v7# l /dev/da1*
/dev/da1    /dev/da1s1

from disktype:

root@kg-v7# disktype /dev/da1

--- /dev/da1
Character device, size 991.8 MiB (1039933440 bytes)
DOS/MBR partition map
Partition 1: 991.2 MiB (1039385088 bytes, 2030049 sectors from 63, bootable)
  Type 0x06 (FAT16)
  Windows / MS-DOS boot loader
  FAT16 file system (hints score 5 of 5)
    Volume size 991.0 MiB (1039106048 bytes, 63422 clusters of 16 KiB)

Finally, a Kingston 4GB, no speed rating, /var/log/messages:

Nov 15 19:23:09 kg-v7 kernel: da1: <Generic CF Card Reader 1.01> Removable Direct Access SCSI-0 device
Nov 15 19:23:09 kg-v7 kernel: da1: 40.000MB/s transfers
Nov 15 19:23:09 kg-v7 kernel: da1: 3811MB (7806960 512 byte sectors: 255H 63S/T 485C)

from /dev:

root@kg-v7# l /dev/da1*
/dev/da1    /dev/da1s1

from disktype:

root@kg-v7# disktype /dev/da1

--- /dev/da1
Character device, size 3.723 GiB (3997163520 bytes)
DOS/MBR partition map
Partition 1: 3.719 GiB (3993034752 bytes, 7798896 sectors from 8064, bootable)
  Type 0x0C (Win95 FAT32 (LBA))
  Windows 95/98/ME boot loader
  FAT32 file system (hints score 4 of 5)
    Volume size 3.715 GiB (3988815872 bytes, 121729 clusters of 32 KiB)
    Volume name "KINGSTON"

Wow, even a volume name. That was it.

2013-11-03: ad4s1a - fortunately, the built-in card reader on this machine seems to work without problems:

root@kg-v7# uname -a
FreeBSD kg-v7.kg4.no 8.3-STABLE FreeBSD 8.3-STABLE #0: Sat Jun 16 14:44:53 CEST 2012     root@kg-v7.kg4.no:/usr/obj/usr/src/sys/GENERIC  amd64

the reader

root@kg-v7# usbconfig -u 0 -a 3
ugen0.3: <USB Card Reader Alcor Micro, Corp.> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON

when I insert a card, I get this in /var/log/messages:

Nov  3 22:07:38 kg-v7 kernel: da0 at umass-sim0 bus 0 scbus0 target 0 lun 0
Nov  3 22:07:38 kg-v7 kernel: da0: <Generic SD Card Reader 1.00> Removable Direct Access SCSI-0 device
Nov  3 22:07:38 kg-v7 kernel: da0: 40.000MB/s transfers
Nov  3 22:07:38 kg-v7 kernel: da0: 15079MB (30881792 512 byte sectors: 255H 63S/T 1922C)

no need to manually power off / on and all that. I get messages for the other devices on the reader to, but they say "medium not present" - easy to discard

Nov  3 22:07:38 kg-v7 kernel: da1 at umass-sim0 bus 0 scbus0 target 0 lun 1
Nov  3 22:07:38 kg-v7 kernel: da1: <Generic CF Card Reader 1.01> Removable Direct Access SCSI-0 device
Nov  3 22:07:38 kg-v7 kernel: da1: 40.000MB/s transfers
Nov  3 22:07:38 kg-v7 kernel: da1: Attempt to query device size failed: NOT READY, Medium not present
Nov  3 22:07:38 kg-v7 kernel: da2 at umass-sim0 bus 0 scbus0 target 0 lun 2
Nov  3 22:07:38 kg-v7 kernel: da2: <Generic MS Card Reader 1.03> Removable Direct Access SCSI-0 device
Nov  3 22:07:38 kg-v7 kernel: da2: 40.000MB/s transfers
Nov  3 22:07:38 kg-v7 kernel: da2: Attempt to query device size failed: NOT READY, Medium not present

and I get more on /dev/da0*

root@kg-v7# ls -l /dev/da0*
crw-r-----  1 root  operator    0, 125 Nov  3 22:07 /dev/da0
crw-r-----  1 root  operator    0, 126 Nov  3 22:07 /dev/da0s1

Cool. mount it

root@kg-v7# mount -t msdosfs /dev/da0s1 /media

check

root@kg-v7# df -h /media
Filesystem    Size    Used   Avail Capacity  Mounted on
/dev/da0s1     14G    192k     14G     0%    /media

is there anything on it?

root@kg-v7# ls -F /media/media
books/

Nice, no I just need to copy some ebooks over, and I'm all set.

2013-03-11: ada1p2 - after setting up my new monitor (BenQ GL2450HM), the default Xorg only came up in 640x480! Apparantly, the vesa driver and / or the built in IronLake graphics can't do a DDC transfer and the gets wildly confused about the monitor. After adding HorizSync and VertRefresh to the Monitor section of xorg.conf I at least got 800x600. /etc/X11/xorg.conf new Monitor section:

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "BenQ"
        ModelName    "GL250HM"
        HorizSync    30.0 - 83.0
        VertRefresh  50.0 - 76.0
EndSection

But then Xorg tried the mode 1920x1440, which my monitor refused (max. is 1920x1080). Next, I added some modes to to the 24 bit subsection of the Screen section, and now I get 1280x1024. Not good, but usable. New 24 bit subsection of the Screen section

        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes   "1920x1080" "1280x1024"
        EndSubSection

It doesn't look like vesa has a 1920x1080 mode. Oh well. xrandr says:

tingo@kg-v7$ DISPLAY=:0.0 xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
   1280x1024      76.0*
   1024x768       76.0 
   800x600        73.0 
   640x480        73.0 

Various info from /var/log/Xorg.0.log:

(II) VESA(0): VESA BIOS detected
(II) VESA(0): VESA VBE Version 3.0
(II) VESA(0): VESA VBE Total Mem: 32704 kB
(II) VESA(0): VESA VBE OEM: Intel(R)Ironlake Desktop Graphics Chipset Accelerated VGA BIOS
(II) VESA(0): VESA VBE OEM Software Rev: 1.0
(II) VESA(0): VESA VBE OEM Vendor: Intel Corporation
(II) VESA(0): VESA VBE OEM Product: Intel(R)Ironlake Desktop Graphics Controller
(II) VESA(0): VESA VBE OEM Product Rev: Hardware Version 0.0

(II) LoadModule: "ddc"
(II) Module "ddc" already built-in
(==) VESA(0): Write-combining range (0x0,0x1000) was already clear
(==) VESA(0): Write-combining range (0x0,0x1000) was already clear
(II) VESA(0): VESA VBE DDC supported
(II) VESA(0): VESA VBE DDC Level 2
(II) VESA(0): VESA VBE DDC transfer in appr. 1 sec.
(==) VESA(0): Write-combining range (0x0,0x1000) was already clear
(==) VESA(0): Write-combining range (0x0,0x1000) was already clear
(II) VESA(0): VESA VBE DDC read failed
(==) VESA(0): Write-combining range (0x0,0x1000) was already clear
(==) VESA(0): Write-combining range (0x0,0x1000) was already clear
(II) VESA(0): VESA VBE PanelID invalid

(II) VESA(0): Total Memory: 511 64KB banks (32704kB)
(II) VESA(0): Monitor0: Using hsync range of 30.00-83.00 kHz
(II) VESA(0): Monitor0: Using vrefresh range of 50.00-76.00 Hz
(II) VESA(0): Not using mode "1920x1080" (no mode of this name)
(II) VESA(0): Not using built-in mode "1280x1024" (no mode of this name)
(II) VESA(0): Not using built-in mode "1920x1440" (no mode of this name)
(II) VESA(0): Not using built-in mode "1600x1200" (no mode of this name)
(II) VESA(0): Not using built-in mode "1024x768" (no mode of this name)
(II) VESA(0): Not using built-in mode "800x600" (no mode of this name)
(II) VESA(0): Not using built-in mode "640x480" (no mode of this name)
(WW) VESA(0): No valid modes left. Trying less strict filter...
(II) VESA(0): Monitor0: Using hsync range of 30.00-83.00 kHz
(II) VESA(0): Monitor0: Using vrefresh range of 50.00-76.00 Hz
(II) VESA(0): Not using mode "1920x1080" (no mode of this name)
(II) VESA(0): Not using built-in mode "1920x1440" (width too large for virtual size)
(II) VESA(0): Not using built-in mode "1600x1200" (width too large for virtual size)
(--) VESA(0): Virtual size is 1280x1024 (pitch 1280)
(**) VESA(0): *Built-in mode "1280x1024"
(**) VESA(0):  Built-in mode "1024x768"
(**) VESA(0):  Built-in mode "800x600"
(**) VESA(0):  Built-in mode "640x480"
(==) VESA(0): DPI set to (96, 96)
(II) VESA(0): Attempting to use 75Hz refresh for mode "1280x1024" (11b)
(==) VESA(0): Write-combining range (0x0,0x1000) was already clear
(==) VESA(0): Write-combining range (0x0,0x1000) was already clear
(II) VESA(0): Attempting to use 75Hz refresh for mode "1024x768" (118)
(==) VESA(0): Write-combining range (0x0,0x1000) was already clear
(==) VESA(0): Write-combining range (0x0,0x1000) was already clear
(II) VESA(0): Attempting to use 72Hz refresh for mode "800x600" (115)
(==) VESA(0): Write-combining range (0x0,0x1000) was already clear
(==) VESA(0): Write-combining range (0x0,0x1000) was already clear
(II) VESA(0): Attempting to use 73Hz refresh for mode "640x480" (112)
(==) VESA(0): Write-combining range (0x0,0x1000) was already clear
(==) VESA(0): Write-combining range (0x0,0x1000) was already clear
(**) VESA(0): Using "Shadow Framebuffer"

(II) VESA(0): VESA BIOS detected
(II) VESA(0): VESA VBE Version 3.0
(II) VESA(0): VESA VBE Total Mem: 32704 kB
(II) VESA(0): VESA VBE OEM: Intel(R)Ironlake Desktop Graphics Chipset Accelerated VGA BIOS
(II) VESA(0): VESA VBE OEM Software Rev: 1.0
(II) VESA(0): VESA VBE OEM Vendor: Intel Corporation
(II) VESA(0): VESA VBE OEM Product: Intel(R)Ironlake Desktop Graphics Controller
(II) VESA(0): VESA VBE OEM Product Rev: Hardware Version 0.0
(II) VESA(0): virtual address = 0x804c00000,
        physical address = 0xe0000000, size = 33488896

(II) VESA(0): Setting up VESA Mode 0x11B (1280x1024)

(==) VESA(0): Default visual is TrueColor
(==) VESA(0): Backing store disabled
(==) VESA(0): DPMS enabled
(==) RandR enabled

that's all.

2013-02-21: ada1p2 - I haven't received the daily mails for a few days, so I checked why. It looks like a sshfs process (where the mount had disappeared, timeout?) managed to block the find command of /etc/periodic/security/100.chksetuid. Relevant output from 'ps ax':

96850 ??  Is        0:00.00 /bin/sh - /usr/sbin/periodic daily
96857 ??  I         0:00.01 /bin/sh - /usr/sbin/periodic daily
96858 ??  I         0:00.00 mail -E -s kg-v7.kg4.no daily run output root
96959 ??  I         0:00.00 /bin/sh /etc/periodic/daily/450.status-security
96960 ??  I         0:00.00 /bin/sh - /usr/sbin/periodic security
96967 ??  I         0:00.00 /bin/sh - /usr/sbin/periodic security
96968 ??  I         0:00.00 mail -E -s kg-v7.kg4.no security run output root
96969 ??  I         0:00.00 /bin/sh - /etc/periodic/security/100.chksetuid
96973 ??  D         0:00.02 find -sx / /dev/null -type f ( -perm -u+x -or -perm -g+x -or -perm -o+x ) ( -perm -u+s -
96974 ??  I         0:00.00 /bin/sh - /etc/periodic/security/100.chksetuid
96976 ??  I         0:00.00 cat
99399 ??  I         0:00.00 cron: running job (cron)
99401 ??  Is        0:00.00 /bin/sh - /usr/sbin/periodic daily
99408 ??  I         0:00.01 /bin/sh - /usr/sbin/periodic daily
99409 ??  I         0:00.00 mail -E -s kg-v7.kg4.no daily run output root
99510 ??  I         0:00.00 /bin/sh /etc/periodic/daily/450.status-security
99511 ??  I         0:00.00 /bin/sh - /usr/sbin/periodic security
99518 ??  I         0:00.00 /bin/sh - /usr/sbin/periodic security
99519 ??  I         0:00.00 mail -E -s kg-v7.kg4.no security run output root
99520 ??  I         0:00.00 /bin/sh - /etc/periodic/security/100.chksetuid
99524 ??  D         0:00.01 find -sx / /dev/null -type f ( -perm -u+x -or -perm -g+x -or -perm -o+x ) ( -perm -u+s -
99525 ??  I         0:00.00 /bin/sh - /etc/periodic/security/100.chksetuid
99527 ??  I         0:00.00 cat

this is the offending process:

95926 ??  Is        0:00.31 sshfs tingo@v2:/home/tingo/music /home/tingo/mpoint

but 'df' output showed that /home/tingo/mpoint wasn't mounted, so I killed it:

root@kg-v7# kill -HUP 95926

after that the daily scripts finished, and I got my mails:

root@kg-v7# mail
Mail version 8.1 6/6/93.  Type ? for help.
"/var/mail/root": 4 messages 4 new
>N  1 root@kg-v7.kg4.no     Thu Feb 21 17:50  41/1128  "kg-v7.kg4.no security run output"
 N  2 root@kg-v7.kg4.no     Thu Feb 21 17:50  69/2410  "kg-v7.kg4.no daily run output"
 N  3 root@kg-v7.kg4.no     Thu Feb 21 17:50  42/1215  "kg-v7.kg4.no security run output"
 N  4 root@kg-v7.kg4.no     Thu Feb 21 17:50  69/2410  "kg-v7.kg4.no daily run output"
&

Strange. I will have to run a few more tests.

2013-02-19: ada1p2 - Xorg. It works with the vesa driver. From /var/log/Xorg.0.log:

(--) PCI:*(0:0:2:0) 8086:0042:1043:8383 Intel Corporation Core Processor Integrated Graphics Controller rev 18, Mem @ 0xf7800000/4194304, 0xe0000000/268435456, I/O @ 0x0000dc00/8, BIOS @ 0x????????/65536

(II) VESA(0): VESA BIOS detected
(II) VESA(0): VESA VBE Version 3.0
(II) VESA(0): VESA VBE Total Mem: 32704 kB
(II) VESA(0): VESA VBE OEM: Intel(R)Ironlake Desktop Graphics Chipset Accelerated VGA BIOS
(II) VESA(0): VESA VBE OEM Software Rev: 1.0
(II) VESA(0): VESA VBE OEM Vendor: Intel Corporation
(II) VESA(0): VESA VBE OEM Product: Intel(R)Ironlake Desktop Graphics Controller
(II) VESA(0): VESA VBE OEM Product Rev: Hardware Version 0.0

(==) VESA(0): Depth 24, (--) framebuffer bpp 32
(==) VESA(0): RGB weight 888
(==) VESA(0): Default visual is TrueColor
(==) VESA(0): Using gamma correction (1.0, 1.0, 1.0)

(II) VESA(0): VESA VBE DDC supported
(II) VESA(0): VESA VBE DDC Level 2
(II) VESA(0): VESA VBE DDC transfer in appr. 1 sec.
(==) VESA(0): Write-combining range (0x0,0x1000) was already clear
(==) VESA(0): Write-combining range (0x0,0x1000) was already clear
(II) VESA(0): VESA VBE DDC read successfully
(II) VESA(0): Manufacturer: CPQ  Model: 1395  Serial#: 18285276
(II) VESA(0): Year: 2001  Week: 50
(II) VESA(0): EDID Version: 1.3
(II) VESA(0): Analog Display Input,  Input Voltage Level: 0.700/0.700 V
(II) VESA(0): Sync:  Separate  Composite  SyncOnGreen
(II) VESA(0): Max Image Size [cm]: horiz.: 36  vert.: 29
(II) VESA(0): Gamma: 2.20
(II) VESA(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
(II) VESA(0): First detailed timing is preferred mode
(II) VESA(0): redX: 0.633 redY: 0.340   greenX: 0.295 greenY: 0.591
(II) VESA(0): blueX: 0.141 blueY: 0.096   whiteX: 0.312 whiteY: 0.328
(II) VESA(0): Supported established timings:
(II) VESA(0): 720x400@70Hz
(II) VESA(0): 640x480@60Hz
(II) VESA(0): 640x480@67Hz
(II) VESA(0): 640x480@72Hz
(II) VESA(0): 640x480@75Hz
(II) VESA(0): 800x600@60Hz
(II) VESA(0): 800x600@72Hz
(II) VESA(0): 800x600@75Hz
(II) VESA(0): 832x624@75Hz
(II) VESA(0): 1024x768@60Hz
(II) VESA(0): 1024x768@70Hz
(II) VESA(0): 1024x768@75Hz
(II) VESA(0): 1280x1024@75Hz
(II) VESA(0): 1152x864@75Hz
(II) VESA(0): Manufacturer's mask: 0
(II) VESA(0): Supported standard timings:
(II) VESA(0): #0: hsize: 1280  vsize 1024  refresh: 60  vid: 32897
(II) VESA(0): #1: hsize: 1280  vsize 1024  refresh: 85  vid: 39297
(II) VESA(0): #2: hsize: 1024  vsize 768  refresh: 85  vid: 22881
(II) VESA(0): #3: hsize: 800  vsize 600  refresh: 85  vid: 22853
(II) VESA(0): #4: hsize: 640  vsize 480  refresh: 85  vid: 22833
(II) VESA(0): Supported detailed timing:
(II) VESA(0): clock: 108.0 MHz   Image Size:  360 x 290 mm
(II) VESA(0): h_active: 1280  h_sync: 1328  h_sync_end 1440 h_blank_end 1688 h_border: 0
(II) VESA(0): v_active: 1024  v_sync: 1025  v_sync_end 1028 v_blanking: 1066 v_border: 0
(II) VESA(0): Ranges: V min: 58 V max: 85 Hz, H min: 32 H max: 91 kHz, PixClock max 160 MHz
(II) VESA(0): Serial No: 935EA05YA001
(II) VESA(0): Monitor name: CPQ TFT8030

(II) VESA(0): EDID vendor "CPQ", prod id 5013
(II) VESA(0): Using EDID range info for horizontal sync
(II) VESA(0): Using EDID range info for vertical refresh
(II) VESA(0): Printing DDC gathered Modelines:
(II) VESA(0): Modeline "1280x1024"x0.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz)
(II) VESA(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
(II) VESA(0): Modeline "640x480"x0.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz)
(II) VESA(0): Modeline "640x480"x0.0   31.50  640 664 704 832  480 489 492 520 -hsync -vsync (37.9 kHz)
(II) VESA(0): Modeline "640x480"x0.0   30.24  640 704 768 864  480 483 486 525 -hsync -vsync (35.0 kHz)
(II) VESA(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
(II) VESA(0): Modeline "720x400"x0.0   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz)
(II) VESA(0): Modeline "1280x1024"x0.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz)
(II) VESA(0): Modeline "1024x768"x0.0   78.75  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.0 kHz)
(II) VESA(0): Modeline "1024x768"x0.0   75.00  1024 1048 1184 1328  768 771 777 806 -hsync -vsync (56.5 kHz)
(II) VESA(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
(II) VESA(0): Modeline "832x624"x0.0   57.28  832 864 928 1152  624 625 628 667 -hsync -vsync (49.7 kHz)
(II) VESA(0): Modeline "800x600"x0.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz)
(II) VESA(0): Modeline "800x600"x0.0   50.00  800 856 976 1040  600 637 643 666 +hsync +vsync (48.1 kHz)
(II) VESA(0): Modeline "1152x864"x0.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz)
(II) VESA(0): Modeline "1280x1024"x0.0  157.50  1280 1344 1504 1728  1024 1025 1028 1072 +hsync +vsync (91.1 kHz)
(II) VESA(0): Modeline "1024x768"x0.0   94.50  1024 1072 1168 1376  768 769 772 808 +hsync +vsync (68.7 kHz)
(II) VESA(0): Modeline "800x600"x0.0   56.25  800 832 896 1048  600 601 604 631 +hsync +vsync (53.7 kHz)
(II) VESA(0): Modeline "640x480"x0.0   36.00  640 696 752 832  480 481 484 509 -hsync -vsync (43.3 kHz)

(II) VESA(0): Total Memory: 511 64KB banks (32704kB)
(II) VESA(0): Monitor0: Using hsync range of 32.00-91.00 kHz
(II) VESA(0): Monitor0: Using vrefresh range of 58.00-85.00 Hz
(II) VESA(0): Monitor0: Using maximum pixel clock of 160.00 MHz
(WW) VESA(0): Unable to estimate virtual size
(II) VESA(0): Not using built-in mode "1920x1440" (no mode of this name)
(II) VESA(0): Not using built-in mode "1600x1200" (no mode of this name)

(--) VESA(0): Virtual size is 1280x1024 (pitch 1280)
(**) VESA(0): *Built-in mode "1280x1024"
(**) VESA(0): *Built-in mode "1024x768"
(**) VESA(0): *Built-in mode "800x600"
(**) VESA(0): *Built-in mode "640x480"
(**) VESA(0): Display dimensions: (360, 290) mm
(**) VESA(0): DPI set to (90, 89)
(**) VESA(0): Using "Shadow Framebuffer"

That is all for now.

2013-01-17: ada1p2 - hw monitoring. adding aibs(4) to /boot/loader.conf, like this:

aibs_load="YES"

results in this in dmesg output:

aibs0: <ASUSTeK AI Booster (ACPI ASOC ATK0110)> on acpi0
aibs0: V0: 0x06020000        Vcore Voltage   850 /  1600  0x1
aibs0: V1: 0x06020001         +3.3 Voltage  2970 /  3630  0x1
aibs0: V2: 0x06020002           +5 Voltage  4500 /  5500  0x1
aibs0: V3: 0x06020003          +12 Voltage 10200 / 13800  0x1
aibs0: T0: 0x06030000      CPU Temperature   600 /   950  0x10001
aibs0: T1: 0x06030001       MB Temperature   550 /   950  0x10001
aibs0: F0: 0x06040000        CPU FAN Speed   600 /  7200  0x10001
aibs0: F1: 0x06040001    CHASSIS FAN Speed   600 /  7200  0x10001
aibs0: F2: 0x06040002      POWER FAN Speed   600 /  7200  0x10001

sysctl can be used to report descriptions:

root@kg-v7# sysctl -d dev.aibs.0
dev.aibs.0:
dev.aibs.0.volt.0: Vcore Voltage
dev.aibs.0.volt.1:  +3.3 Voltage
dev.aibs.0.volt.2:  +5 Voltage
dev.aibs.0.volt.3:  +12 Voltage
dev.aibs.0.temp.0: CPU Temperature
dev.aibs.0.temp.1: MB Temperature
dev.aibs.0.fan.0: CPU FAN Speed
dev.aibs.0.fan.1: CHASSIS FAN Speed
dev.aibs.0.fan.2: POWER FAN Speed
dev.aibs.0.%desc: device description
dev.aibs.0.%driver: device driver name
dev.aibs.0.%location: device location relative to parent
dev.aibs.0.%pnpinfo: device identification
dev.aibs.0.%parent: parent device

and values:

root@kg-v7# sysctl  dev.aibs.0
dev.aibs.0.volt.0: 928 850 1600
dev.aibs.0.volt.1: 3360 2970 3630
dev.aibs.0.volt.2: 5120 4500 5500
dev.aibs.0.volt.3: 12249 10200 13800
dev.aibs.0.temp.0: 42.0C 60.0C 95.0C
dev.aibs.0.temp.1: 35.0C 55.0C 95.0C
dev.aibs.0.fan.0: 1188 600 7200
dev.aibs.0.fan.1: 0 600 7200
dev.aibs.0.fan.2: 0 600 7200
dev.aibs.0.%desc: ASUSTeK AI Booster (ACPI ASOC ATK0110)
dev.aibs.0.%driver: aibs
dev.aibs.0.%location: handle=\_SB_.PCI0.SBRG.ASOC
dev.aibs.0.%pnpinfo: _HID=ATK0110 _UID=16843024
dev.aibs.0.%parent: acpi0

a handy alias is this:

root@kg-v7# alias atemp='echo -n "CPU: ";sysctl  -n dev.aibs.0.temp.0;echo -n "MB:  ";sysctl -n dev.aibs.0.temp.1'
root@kg-v7# atemp
CPU: 42.0C 60.0C 95.0C
MB:  35.0C 55.0C 95.0C

compared to temp (from the coretemp module)

root@kg-v7# temp
dev.cpu.0.temperature: 37.0C
dev.cpu.1.temperature: 37.0C
dev.cpu.2.temperature: 37.0C
dev.cpu.3.temperature: 37.0C

Hmm, different values.

2013-01-16: ada1p2 - testing another ps/2 kbd and mouse adapter (a grey thing, with grey leads for the usb plug, mouse and keyboard contacts. It has a green-colored mouse contact and a purple-colored connector for the keyboard). I connected the adapter (it has no visual indicators) and this is what shows up in /var/log/messages:

Jan 16 19:35:52 kg-v7 kernel: ukbd1: <vendor 0x13ba Generic USB KB, class 0/0, rev 1.10/0.01, addr 3> on usbus0
Jan 16 19:35:52 kg-v7 kernel: kbd3 at ukbd1
Jan 16 19:35:52 kg-v7 kernel: ums1: <vendor 0x13ba Generic USB KB, class 0/0, rev 1.10/0.01, addr 3> on usbus0
Jan 16 19:35:52 kg-v7 kernel: ums1: 3 buttons and [XYZ] coordinates ID=1

plugged the mouse in - it doesn't work. Connected a keyboard - that doesn't work either. This adapter is broken.

2013-01-16: ada1p2 - testing a small ps/2 kbd and mouse adapter (small blue thingy with a usb plug on it, and two ps/2 contacts). I just connected the adapter, the red LED on it turned on, and I got this in /var/log/messages:

Jan 16 19:27:34 kg-v7 kernel: ugen0.3: <GASIA> at usbus0
Jan 16 19:27:34 kg-v7 kernel: ukbd1: <GASIA PS2toUSB Adapter, class 0/0, rev 1.10/2.80, addr 3> on usbus0
Jan 16 19:27:34 kg-v7 kernel: kbd3 at ukbd1
Jan 16 19:27:34 kg-v7 kernel: ums1: <GASIA PS2toUSB Adapter, class 0/0, rev 1.10/2.80, addr 3> on usbus0
Jan 16 19:27:34 kg-v7 kernel: ums1: 5 buttons and [XYZ] coordinates ID=1

then I plugged a mouse into the mouse port on the adapter - it works, end of test.

2013-01-06: ada1p2 - I added the coretemp module:

root@kg-v7# more /boot/loader.conf
coretemp_load="YES"

which gets me cpu temperatures, like this:

root@kg-v7# sysctl dev.cpu.0.temperature;sysctl dev.cpu.1.temperature;sysctl dev.cpu.2.temperature;sysctl dev.cpu.3.temperature
dev.cpu.0.temperature: 35.0C
dev.cpu.1.temperature: 35.0C
dev.cpu.2.temperature: 34.0C
dev.cpu.3.temperature: 34.0C

That's all.

2013-01-06 - ada1p2 - I used portsnap fetch; portsnap update to update the ports tree.

2013-01-06 - ada1p2 - FreeBSD 9.1-stable. dmesg output normal, verbose.

tingo@kg-v7$ uname -a
FreeBSD kg-v7.kg4.no 9.1-STABLE FreeBSD 9.1-STABLE #0: Sun Jan  6 20:09:55 CET 2013     root@kg-v7.kg4.no:/usr/obj/usr/src/sys/GENERIC  amd64

2013-01-06 - ada1p2 - upgrading to latest FreeBSD 9.1-stable via csup, make world. On the first try, make kernel failed with:

--------------------------------------------------------------
>>> Kernel build for GENERIC completed on Sun Jan  6 20:18:15 CET 2013
--------------------------------------------------------------
ERROR: Required auditdistd user is missing, see /usr/src/UPDATING.
*** [installcheck_UGID] Error code 1

Stop in /usr/src.
*** [installkernel] Error code 1

Stop in /usr/src.

Ok, fix that by running mergemaster -p, then re-run make installkernel. That fixed it.